summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzan2020-07-18 00:39:17 -0400
committerzan2020-07-18 00:39:17 -0400
commit39025912359fa9f1dd2045553a90916c7b0cbaf5 (patch)
tree0961f8ee7a35189826c9202a3462c496d82c3fa4 /PKGBUILD
downloadaur-39025912359fa9f1dd2045553a90916c7b0cbaf5.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7327a72f2a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: zan <zan@420blaze.it>
+
+pkgname=kwayland-server-git
+_name=${pkgname%-git}
+pkgver=v5.19.1.r65.g8351f51
+pkgrel=1
+pkgdesc='Wayland Server Components built on KDE Frameworks '
+arch=(x86_64)
+url='https://invent.kde.org/plasma/kwayland-server'
+license=(LGPL)
+depends=(qt5-base)
+makedepends=(git extra-cmake-modules-git plasma-wayland-protocols wayland-protocols kwayland doxygen qt5-tools)
+conflicts=(kwayland-server)
+provides=(kwayland-server)
+groups=(plasma)
+source=("git+https://invent.kde.org/plasma/$_name.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S $_name
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+
+
+