summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHanabishi2021-11-10 13:15:39 +0500
committerHanabishi2021-11-10 13:15:39 +0500
commit6e6dbf92279b33d5b01653c14ca2620cc77322a7 (patch)
treec547fe08738dcb2ee931ba946c88f4b75f3d8f83 /PKGBUILD
downloadaur-6e6dbf92279b33d5b01653c14ca2620cc77322a7.tar.gz
Init package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..420718c651df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Set this flag to 1 if you want to hide Bismuth tray icon.
+HIDE_TRAY_ICON=0
+
+pkgname=kwin-bismuth-bin
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Addon for KDE Plasma to arrange your windows automatically and switch between them using keyboard shortcuts, like tiling window managers."
+arch=('x86_64')
+url="https://github.com/Bismuth-Forge/bismuth"
+license=('MIT')
+depends=('systemsettings')
+makedepends=()
+provides=("bismuth=${pkgver}" "kwin-bismuth=${pkgver}")
+conflicts=('bismuth')
+options=('!emptydirs')
+
+source=(
+ "bismuth-bin-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/binary-release.tar.gz"
+ 'hide-tray-icon.patch'
+)
+
+sha512sums=(
+ '3cb3eab9a3109331e3f1b0ea94466e9250b26964c7136bb94470b55254a70e343961536830cb18522c558d3ba28513f3d52d1a697ce9e0faa6789b99ed027ed6'
+ 'aab3cecfcb8dcfcb1a367a264fb2e95c446ceb9d2588eec51a98455936dde4fe62daa483952a437c7cb903105a3371ebb137d6e1c512ea9dc11b9c7baced101c'
+)
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 -t "${pkgdir}/usr/lib/qt/plugins/kcms/" "./lib/x86_64-linux-gnu/plugins/kcms/kcm_bismuth.so"
+
+ rm "./share/icons/hicolor/icon-theme.cache"
+
+ if [ ${HIDE_TRAY_ICON} = 1 ]; then
+ patch -p0 -N -i "hide-tray-icon.patch"
+ fi
+
+ cp -r "./share/" "${pkgdir}/usr/"
+}