summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlejandro Valdes2020-02-15 20:18:12 -0500
committerAlejandro Valdes2020-02-15 20:18:12 -0500
commit3fb79291be1a1c6e8249e4aa06d0d45fb9672c39 (patch)
treec43b7361cd34ded31b74d687ec6cdea7074bc660 /PKGBUILD
parentb58985809343096956d2d6772cb66828d74dc368 (diff)
downloadaur-3fb79291be1a1c6e8249e4aa06d0d45fb9672c39.tar.gz
Fixed compilation with plasma 5.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56c676a5419b..4a69958535e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
pkgname=kwin-effects-yet-another-magic-lamp
pkgver=4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Just Yet Another Magic Lamp effect"
arch=('x86_64')
url="https://github.com/zzag/$pkgname"
license=('GPL3')
-depends=(kwin)
+depends=('kwin>=5.18.0')
makedepends=(extra-cmake-modules)
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zzag/${pkgname}/archive/${pkgver}.tar.gz)
-sha256sums=('12832e90ab52bb32239b8b1f4e3039250b68486f37e82e88c85eba89651fcb99')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zzag/${pkgname}/archive/${pkgver}.tar.gz
+ f411876086099638677d35c4cc023e5d046eff6a.patch)
+sha256sums=('12832e90ab52bb32239b8b1f4e3039250b68486f37e82e88c85eba89651fcb99'
+ '74c7ba20069bb61f0291dd9f40535a943eefc1a69f5e350001bc36951ddb980c')
prepare() {
mkdir -p build
+ cd $srcdir/$pkgname-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/f411876086099638677d35c4cc023e5d046eff6a.patch"
}
build() {