summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Albers2020-03-12 01:32:27 +0100
committerDaniel Albers2020-03-12 01:32:27 +0100
commit310de91c42e31eb0758794319f03770b5e606381 (patch)
treee57defd536bb4951ffddbce2c6a77179e2fbb8da /PKGBUILD
parenta1b8349fd8749664624e84b64f6172d099b96692 (diff)
downloadaur-310de91c42e31eb0758794319f03770b5e606381.tar.gz
Use tag based versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 277022bebe98..639216537fee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
pkgname=kwindowsystem-git
-pkgver=r136.487f03a
-pkgrel=2
+pkgver=v4.100.0.rc1.r395.g0e2b1dd
+pkgrel=1
pkgdesc='KWindowSystem'
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/frameworks/kwindowsystem'
@@ -16,8 +16,8 @@ source=('git://anongit.kde.org/kwindowsystem.git')
md5sums=('SKIP')
pkgver() {
- cd kwindowsystem
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname%-git}
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {