summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorabelian4242024-01-07 14:00:42 +0600
committerabelian4242024-01-07 14:00:42 +0600
commitb63845b339f0dd0993bf21c67bf0bfd0629264d1 (patch)
tree88a101fda98d990e9a091d6322850d64cdc2366f /PKGBUILD
parentf1089fda984d93a0fe59ad22a6edebede516c27f (diff)
downloadaur-b63845b339f0dd0993bf21c67bf0bfd0629264d1.tar.gz
Updated to build correctly against -git versions of kde-unstable packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9644d40f1006..1e5508f96498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,30 @@
_pkgname=kwin
pkgname=kwinft-git
-pkgver=5.27.0.beta.0.r764.gd913702e3
+pkgver=5.27.9
pkgrel=1
pkgdesc='drop-in replacement for KWin with additional libwayland wrapping Qt/C++ library Wrapland'
arch=(x86_64)
url="https://gitlab.com/kwinft/kwinft"
license=(LGPL)
-depends=(python xcb-util-cursor plasma-framework kcmutils kio breeze kinit qt6-sensors wrapland disman kscreen kscreenlocker pipewire libqaccessibilityclient-qt6 xorg-xwayland kdeclarative wlroots)
-makedepends=(git 'extra-cmake-modules>=5.240.0' qt6-tools kdoctools)
-optdepends=('qt6-virtualkeyboard: virtual keyboard support for kwin-wayland')
+depends=(python xcb-util-cursor qt6-sensors wrapland-git disman-git kdisplay-git wlroots \
+ xorg-xwayland qt6-multimedia pipewire microsoft-gsl \
+ knewstuff-git kdecoration-git kcmutils-git kio-git kdeclarative-git kscreenlocker-git)
+makedepends=(git qt6-tools kdoctools extra-cmake-modules-git)
+optdepends=('qt6-virtualkeyboard: virtual keyboard support for kwin-wayland' \
+ 'libplasma: plasma-framework6' \
+ 'breeze>=5.80.0' \
+ 'libqaccessibilityclient-qt6' \
+ 'libkscreen-git: needed if kscreenlocker-git is used' )
provides=("$_pkgname=${pkgver}" "kwinft=${pkgver}")
conflicts=("$_pkgname" "kwinft")
-source=("$_pkgname::git+https://gitlab.com/kwinft/kwinft.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.com/kwinft/kwinft.git")
+sha256sum=
install=kwinft.install
pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed 's/^kwinft\@//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname/-git}"
+ git describe --long | sed 's/^kwinft\@//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -31,10 +37,10 @@ prepare() {
build() {
cd "$srcdir"/build
- cmake "$srcdir"/$_pkgname \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ cmake "$srcdir"/${pkgname/-git} \
+ -DQT_MAJOR_VERSION=6 \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
make
}
@@ -43,3 +49,4 @@ package() {
cd "$srcdir"/build
make DESTDIR="$pkgdir" install
}
+sha256sums=('SKIP')