summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:03:39 +0200
committersl1pkn072015-06-08 17:03:39 +0200
commit4b1cd03befeae812ce75e177836067227da9dc71 (patch)
tree081abe91fb5b2ced4994dcba8e6625bf6af93b46 /PKGBUILD
downloadaur-4b1cd03befeae812ce75e177836067227da9dc71.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0faa6c983dbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Jimmy Bergstrom <thekwarf@gmail.com>
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+
+pkgname=kwooty-frameworks-git
+pkgver=1.1.0.r1223.586cab9
+pkgrel=1
+pkgdesc="A friendly nzb usenet binary downloader for KDE. KF5 frameworks branch (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://kwooty.sourceforge.net/"
+license=('GPL')
+depends=('kdelibs4support' 'kcmutils' 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'kdoctools')
+optdepends=('unrar: automatic RAR-archive extraction'
+ 'p7zip: automatic zip and 7z archive extraction'
+ 'par2cmdline: automatic file repairing')
+install="${pkgname}.install"
+source=('git://anongit.kde.org/kwooty#branch=frameworks')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd kwooty
+ _ver=$(cat src/main.cpp | grep 'ki18n("Kwooty"),' | cut -d '"' -f4)
+ echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kwooty \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}