summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2021-04-16 16:39:34 +0200
committerNarrat2021-04-16 16:39:34 +0200
commit8ebc6a4f9a46461fe2d9ff290f567ce4f371996f (patch)
tree43287d9836faf507a4a7831394685249cbdeb6df /PKGBUILD
parent07361dde7566f640ea30c8799dd1a5e4785313e5 (diff)
downloadaur-8ebc6a4f9a46461fe2d9ff290f567ce4f371996f.tar.gz
labwc: update to 0.2.0
update for wlroots 0.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78be6221d7af..e902d254ed1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lex Black <autumn-wind@web.de>
pkgname=labwc
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc='stacking wayland compositor with look and feel from openbox'
url="https://github.com/johanmalm/labwc"
@@ -10,10 +10,17 @@ license=('GPL2')
depends=('pango' 'wlroots' 'wayland' 'wayland-protocols' 'xorg-xwayland')
makedepends=('meson' 'scdoc')
optdepends=("bemenu: default launcher via Alt+F3")
-source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/0.1.0.tar.gz")
-b2sums=('336b2949e2306f9dcbe4786c0b28e70cef0b9d999276d88890e25933297ba433ce297dc0c0e0376c1267bc0d3ff3a7b798db32d04c6f297d2803f5167f8cf503')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/${pkgver}.tar.gz"
+ wlroots_error.patch)
+b2sums=('ec4853cd2d839253a1389d7cb7216e4f7c8e8e485fd73b919cad6e7f0afe1f168a9aad0d07447b4fe59a56c3118b2886d7c7fd2ea47646854f5781f287424d59'
+ '6305177a8cb60e8aa8018178895e431d61e2bd37cd4fb17ca1470965c235b030952daa02f7e3d251c698e67a2dbd53055e0cdeb18e8a20106c8d1f15f8476b9d')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}"/wlroots_error.patch
+}
+
build() {
cd "$pkgname-$pkgver"
arch-meson -Dman-pages=enabled ../build