summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredtide2023-07-01 15:42:33 +0200
committerredtide2023-07-01 15:59:41 +0200
commita9305a0382051a726762445ff17ad4a9ab29ad0b (patch)
treee67d752b3c82a4ab2314bc1bd74ac9a51aeb2a32 /PKGBUILD
downloadaur-a9305a0382051a726762445ff17ad4a9ab29ad0b.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3d30ad06c30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: redtide <redtid3@gmail.com>
+
+_pkgname=labwc-tweaks
+pkgname=$_pkgname-git
+pkgver=r57.c52dc16
+pkgrel=1
+pkgdesc="Simple configuration GUI application for labwc"
+url="https://github.com/labwc/labwc-tweaks"
+license=(GPL2)
+arch=(x86_64)
+depends=(
+ gtk3
+ libxml2
+ wayland
+ wayland-protocols
+)
+makedepends=(
+ meson
+)
+source=(
+ $_pkgname::git+$url.git
+)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ arch-meson "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}