summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier Francisco2019-08-26 01:22:42 +0100
committerXavier Francisco2019-08-26 01:22:42 +0100
commita7c97cf3ec9d0619341a03939e4367e8fabd8499 (patch)
treedbbbc2a0b4f4ab6de2b03814151fceb44d2115b6 /PKGBUILD
downloadaur-a7c97cf3ec9d0619341a03939e4367e8fabd8499.tar.gz
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..888eb71eeb02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Xavier Francisco <echo moc.liamg@ocsicnarf.n.reivax | rev>
+
+# PKGBUILD script for laby upstream, git version
+# Learn programming, playing with ants and spider webs ;-) https://sgimenez.github.io/laby/
+_pkgname=laby
+pkgname=$_pkgname-git
+pkgver=r349.27ecf89
+pkgrel=1
+pkgdesc="Learn programming, playing with ants and spider webs"
+arch=('i686' 'x86_64')
+url="https://sgimenez.github.io/laby/"
+license=('GPL3')
+groups=()
+depends=('lablgtk2')
+makedepends=('ocamlbuild' 'ocaml-findlib')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/sgimenez/laby")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}