summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcopycat-killer2017-02-02 11:31:44 +0100
committercopycat-killer2017-02-02 11:31:44 +0100
commitb278f12493226643a1be09ada28383adb8c4f7fc (patch)
tree2bf88fccd96931d92c2c67a1313a4ea4f5d84d01 /PKGBUILD
parent736df092e2825a203250350ccf86f69af846d565 (diff)
downloadaur-b278f12493226643a1be09ada28383adb8c4f7fc.tar.gz
updated PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15eaf1c9544f..044415c713fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=lain-git
pkgcom=1531
pkgsha=a1ba902
pkgver=$pkgcom.$pkgsha
-pkgrel=1
+pkgrel=2
pkgdesc="Layouts, asynchronous widgets and utilities for Awesome WM"
arch=('any')
url="https://github.com/copycat-killer/lain"
@@ -18,8 +18,8 @@ source=("git://github.com/copycat-killer/lain.git")
md5sums=('SKIP')
package() {
- aw=$(which awesome | grep local) # check if awesome is stable or git
- if [ -z ${#aw} ]; then
+ # check if awesome is stable or git
+ if [ -d "/usr/share/awesome/lib/"]; then
aw_path="$pkgdir/usr/share/awesome/lib"
else
aw_path="$pkgdir/usr/local/share/awesome/lib"
@@ -30,6 +30,6 @@ package() {
rm -rf lain/{wiki,.git*,*.rockspec,*TEMPLATE*}
cp -a lain $aw_path
- # Fix permissions
+ # fix scripts permissions
find "$pkgdir" -type f ! -path "*/scripts/*" -print0 | xargs -0 chmod -R 644
}