summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcopycat-killer2017-01-23 16:32:32 +0100
committercopycat-killer2017-01-23 16:32:32 +0100
commitc2684337a8eac62b30af684e7844a93e6d56e548 (patch)
tree922bf12a02010462c7a010a0d32a4b27d3d00279 /PKGBUILD
parent155e610de02a5acdd8b7b3e3ef7ba20ca1fe895d (diff)
downloadaur-c2684337a8eac62b30af684e7844a93e6d56e548.tar.gz
fixed PKGBUILD: now the real pointed commit is fetched, instead of HEAD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3051762af681..0cea24dffc75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: luke bonham <dada [at] archlinux [dot] info>
pkgname=lain-git
-pkgver=1454.7e4175f
-pkgrel=1
+pkgcom=1454
+pkgsha=7e4175f
+pkgver=$pkgcom.$pkgsha
+pkgrel=2
pkgdesc="Layouts, Utilities and Widgets for Awesome WM"
arch=('any')
url="https://github.com/copycat-killer/lain"
license=('GPL2')
depends=('awesome')
-optdepends=('curl: for IMAP and weather widgets')
+optdepends=('curl: for widgets accessing network resources')
makedepends=('git')
provides=('lain')
conflicts=('lain')
source=("git://github.com/copycat-killer/lain.git")
md5sums=('SKIP')
-pkgver() {
- cd lain
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
package() {
install -dm755 "$pkgdir/usr/share/awesome/lib/lain"
- rm -r lain/{wiki,.git*}
+ git --git-dir=lain/.git --work-tree=lain/ reset --hard $pkgsha --quiet
+ rm -rf lain/{wiki,.git*,*.rockspec,*TEMPLATE*}
cp -a lain "$pkgdir/usr/share/awesome/lib/"
# Fix permissions