summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:20:16 +0200
committerAlexander F Rødseth2015-06-10 15:20:16 +0200
commit91fc3d562f2ed4f837d76b605e564faac5b1f861 (patch)
treeab655bd17b9e316b6ce537d81aebec549525e4eb /PKGBUILD
downloadaur-91fc3d562f2ed4f837d76b605e564faac5b1f861.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a446a1e6bf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=lambdanative
+pkgver=1.0.5
+pkgrel=2
+pkgdesc='Write mobile applications in Scheme'
+arch=('x86_64' 'i686')
+url='https://github.com/part-cw/lambdanative'
+license=('custom')
+depends=('android-sdk' 'android-ndk' 'gambit-c' 'zip')
+#source=("git://github.com/part-cw/lambdanative.git#tag=v$pkgver")
+source=("git://github.com/part-cw/lambdanative.git#commit=98b70e")
+md5sums=('SKIP')
+
+prepare() {
+ cd lambdanative
+ cp SETUP.template SETUP
+ setconf SETUP ANDROIDSDK /opt/android-sdk
+ setconf SETUP ANDROIDNDK /opt/android-ndk
+ sed -i 's-= -=-g' SETUP
+ setconf scripts/lambdanative LAMBDANATIVE /usr/share/lambdanative
+}
+
+package() {
+ install -d "$pkgdir/usr/share"
+ cp -r lambdanative "$pkgdir/usr/share/"
+ install -Dm755 lambdanative/scripts/lambdanative "$pkgdir/usr/bin/lambdanative"
+ install -Dm644 lambdanative/LICENSE "$pkgdir/usr/share/licenses/lambdanative/LICENSE"
+ # Clean up
+ rm -rf "$pkgdir/usr/share/lambdanative/.git"
+ rm "$pkgdir/usr/share/lambdanative/scripts/lambdanative" \
+ "$pkgdir/usr/share/lambdanative/.gitignore" \
+ "$pkgdir/usr/share/lambdanative/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: