summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2021-08-10 16:03:29 -0400
committerDavid Parrish2021-08-10 16:03:29 -0400
commit65adb7047777a9c66fd5fd7d7b2c916155542b9b (patch)
tree8b9f516b3ea7e22e1f4058e138ae9f734b112c32 /PKGBUILD
parent90dc2de33335e3919716b7875e9b903f5203c270 (diff)
downloadaur-lando.tar.gz
Update to version 3.1.4
- Simplify build by removing nvm make dependency. Co-authored-by: mpolishchuck <mpolishchuck@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 3 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 193126857152..5da9f08bb4e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://bbs.archlinux.org/viewtopic.php?id=235884
pkgname=lando
-pkgver=3.0.26
+pkgver=3.1.4
_target_version=${pkgver//_/-}
pkgrel=1
pkgdesc="A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology"
@@ -12,7 +12,7 @@ url="https://docs.devwithlando.io"
license=('GPL')
depends=('docker' 'docker-compose')
optdepends=('gcc-libs')
-makedepends=('npm' 'yarn' 'git' 'nvm')
+makedepends=('npm' 'yarn' 'git' 'nodejs')
source=("${pkgname}::git+https://github.com/lando/lando.git#tag=v${_target_version}")
sha256sums=('SKIP')
conflicts=("lando-git")
@@ -24,19 +24,8 @@ options=(!strip)
build() {
cd "${srcdir}/$pkgname" || exit
- # Use nodejs 10 with NVM
- export npm_config_cache="$srcdir/npm_cache"
- _npm_prefix=$(npm config get prefix)
- npm config delete prefix
- source /usr/share/nvm/init-nvm.sh
- nvm install 10.16.3 && nvm use 10.16.3
-
- npm install
+ yarn install
yarn pkg:cli
-
- # Restore node config from nvm
- npm config set prefix "${_npm_prefix}"
- nvm unalias default
}
package() {