summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2019-09-16 11:33:01 -0400
committerDavid Parrish2019-09-16 11:33:01 -0400
commit02cc404ba82300e753a422320d534669da5e32c4 (patch)
treefd486c1d3ec48e7bac3fc56a09fea6cb42ccb431 /PKGBUILD
parent347d032ef17c74436871d80a05414a385b4e1f48 (diff)
downloadaur-02cc404ba82300e753a422320d534669da5e32c4.tar.gz
Update to version 3.0.0-rc.20
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 935792f4cc53..75ad25f0ed9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://bbs.archlinux.org/viewtopic.php?id=235884
pkgname=lando
-pkgver=3.0.0_rc.16
+pkgver=3.0.0_rc.20
_target_version=${pkgver//_/-}
pkgrel=1
pkgdesc="A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology"
@@ -12,7 +12,7 @@ url="https://docs.devwithlando.io"
license=('GPL')
depends=('docker' 'docker-compose')
optdepends=('gcc-libs')
-makedepends=('npm' 'yarn' 'git')
+makedepends=('npm' 'yarn' 'git' 'nvm')
source=("${pkgname}::git+https://github.com/lando/lando.git#tag=v${_target_version}")
sha256sums=('SKIP')
conflicts=("lando-git")
@@ -24,11 +24,19 @@ options=(!strip)
build() {
cd "${srcdir}/$pkgname" || exit
- # https://github.com/lando/lando/issues/1309
- npm install fs-extra@0.18.4
- npm install
+ # Use nodejs 10 with NVM
+ export npm_config_cache="$srcdir/npm_cache"
+ _npm_prefix=$(npm config get prefix)
+ npm config delete prefix
+ source /usr/share/nvm/init-nvm.sh
+ nvm install 10.16.3 && nvm use 10.16.3
+ npm install
yarn pkg:cli
+
+ # Restore node config from nvm
+ npm config set prefix "${_npm_prefix}"
+ nvm unalias default
}
package() {