summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSR_team2021-02-15 01:11:40 +0300
committerSR_team2021-02-15 01:11:40 +0300
commit47afb38ce65a9385f5188eaa31f1e3081adbb247 (patch)
tree98440771fabda0c2742a26c25135565c1cf8c1fd /PKGBUILD
downloadaur-47afb38ce65a9385f5188eaa31f1e3081adbb247.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e467a40a3725
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=lang815bkg-faustus
+_gitname=lang815bkg-faustus
+pkgver=0.1
+pkgrel=1
+pkgdesc="Backend for lang815 to change keys led color, when language layout is changed for ASUS TUF Gaming series laptops"
+arch=('any')
+url="https://gitlab.com/SR_team/lang815bkg-faustus"
+license=('GPL3')
+depends=('lang815')
+makedepends=('git' 'gcc' 'make' 'cmake')
+install=${pkgname}.install
+options=(!emptydirs)
+source=("git+https://gitlab.com/SR_team/lang815bkg-faustus.git")
+md5sums=('SKIP')
+
+build() {
+ cd ${_gitname}
+ cmake -DCMAKE_BUILD_TYPE=MinSizeRel .
+ make
+}
+
+package() {
+ cd ${_gitname}
+ mkdir -p ${pkgdir}/usr/lib/
+ cp libLang815bkg-faustus.so ${pkgdir}/usr/lib/
+ chmod -R 755 ${pkgdir}/usr
+}