summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-07 23:30:49 -0200
committerDaniel Bermond2018-02-07 23:30:49 -0200
commit6d59e758654e194b6c5347c71ae0328b8ca11538 (patch)
tree582d6053ac198c8bfbb1142ad8315d0c9ac0ca48 /PKGBUILD
parent35d80ad1306f445e2e514a2d5745de2a3d681ed5 (diff)
downloadaur-6d59e758654e194b6c5347c71ae0328b8ca11538.tar.gz
GUI: fix optdepend and path on config script
Python GUI has pyqt5 dependency. Fixing the path on config script makes the GUI to correctly run with the desktop file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cffd5bc342e4..53229dd35674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=laptop-mode-tools
pkgver=1.72.2
-pkgrel=1
-pkgdesc='Power Savings tool for Linux'
+pkgrel=2
+pkgdesc='Power Saving tool for Linux'
arch=('any')
url='https://github.com/rickysarraf/laptop-mode-tools/'
license=('GPL')
@@ -19,7 +19,7 @@ optdepends=('acpid: ACPI support'
'ethtool: Ethernet support'
'wireless_tools: Wi-Fi support'
'xorg-xset: DPMS standby support'
- 'python2-pyside: LMT GUI')
+ 'python-pyqt5: LMT GUI')
backup=('etc/laptop-mode/conf.d/ac97-powersave.conf'
'etc/laptop-mode/conf.d/auto-hibernate.conf'
'etc/laptop-mode/conf.d/battery-level-polling.conf'
@@ -58,6 +58,9 @@ package() {
# use '/bin' instead of '/sbin'
mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
find "$pkgdir" -type f -exec sed -i 's|sbin/laptop_mode|bin/laptop_mode|g' '{}' ';'
-
+
install -D -m755 gui/LMT.py "${pkgdir}/usr/bin/lmt-gui"
+
+ # fix path of gui on config script
+ sed -i 's|/usr/share/laptop-mode-tools/lmt\.py$|/usr/bin/lmt-gui|' "${pkgdir}/usr/bin/lmt-config-gui"
}