summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLev Lybin2015-06-11 22:45:12 +0700
committerLev Lybin2015-06-11 22:45:12 +0700
commitc49782eb287384d53b286c6c21b14c392ad81fe1 (patch)
tree611b2b4b5d12f57749a39c643949e4e8bfa940ae /PKGBUILD
downloadaur-c49782eb287384d53b286c6c21b14c392ad81fe1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9679ba9c1361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Aaditya Bagga <aaditya_gnulinux@zoho.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=laptop-mode-tools
+pkgver=1.66
+pkgrel=3
+_pkgrel=2
+pkgdesc='Power Savings tool for Linux'
+arch=('any')
+url='https://github.com/rickysarraf/laptop-mode-tools'
+source=(https://github.com/rickysarraf/laptop-mode-tools/archive/debian/${pkgver}-${_pkgrel}.tar.gz)
+sha256sums=('c9fa63f501bfbb14167eedefb04f7df8e9d1abd23f2a77896b874b61c076882a')
+license=('GPL2')
+depends=('bash')
+optdepends=('acpid: ACPI support'
+ 'bluez-utils: Bluetooth support'
+ 'hdparm: hard disk power management'
+ 'sdparm: SCSI disk power management'
+ 'ethtool: Ethernet support'
+ 'wireless_tools: Wi-Fi support'
+ 'xorg-xset: DPMS standby support'
+ 'python2-pyside: LMT GUI')
+backup=('etc/laptop-mode/conf.d/ac97-powersave.conf'
+ 'etc/laptop-mode/conf.d/auto-hibernate.conf'
+ 'etc/laptop-mode/conf.d/battery-level-polling.conf'
+ 'etc/laptop-mode/conf.d/bluetooth.conf'
+ 'etc/laptop-mode/conf.d/configuration-file-control.conf'
+ 'etc/laptop-mode/conf.d/cpufreq.conf'
+ 'etc/laptop-mode/conf.d/dpms-standby.conf'
+ 'etc/laptop-mode/conf.d/eee-superhe.conf'
+ 'etc/laptop-mode/conf.d/ethernet.conf'
+ 'etc/laptop-mode/conf.d/exec-commands.conf'
+ 'etc/laptop-mode/conf.d/hal-polling.conf'
+ 'etc/laptop-mode/conf.d/intel-hda-powersave.conf'
+ 'etc/laptop-mode/conf.d/intel-sata-powermgmt.conf'
+ 'etc/laptop-mode/conf.d/lcd-brightness.conf'
+ 'etc/laptop-mode/conf.d/nmi-watchdog.conf'
+ 'etc/laptop-mode/conf.d/pcie-aspm.conf'
+ 'etc/laptop-mode/conf.d/runtime-pm.conf'
+ 'etc/laptop-mode/conf.d/sched-mc-power-savings.conf'
+ 'etc/laptop-mode/conf.d/sched-smt-power-savings.conf'
+ 'etc/laptop-mode/conf.d/start-stop-programs.conf'
+ 'etc/laptop-mode/conf.d/terminal-blanking.conf'
+ 'etc/laptop-mode/conf.d/video-out.conf'
+ 'etc/laptop-mode/conf.d/wireless-ipw-power.conf'
+ 'etc/laptop-mode/conf.d/wireless-iwl-power.conf'
+ 'etc/laptop-mode/conf.d/wireless-power.conf'
+ 'etc/laptop-mode/laptop-mode.conf'
+ 'etc/laptop-mode/lm-profiler.conf')
+
+package() {
+ cd "laptop-mode-tools-debian-${pkgver}-${_pkgrel}"
+
+ make DESTDIR="${pkgdir}" MAN_D=/usr/share/man LIB_D=/usr/lib PREFIX=/usr INIT_D=false install
+ # use /bin instead of /sbin
+ mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
+ find "${pkgdir}" -type f -exec sed -i 's|sbin/laptop_mode|bin/laptop_mode|g' '{}' ';'
+
+ install -Dm755 gui/LMT.py "${pkgdir}/usr/bin/lmt-gui"
+}