summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:54:17 +0000
committerOtto Sabart2015-06-30 09:54:17 +0000
commit0373c843eb553906f8d88c62191a38c855c74c38 (patch)
treea48430da5c2aa7b050b2ef1621cd60c9995e47c0 /PKGBUILD
downloadaur-lastfmlib.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233824886342
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+
+pkgname=lastfmlib
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A library that provides an implementation of the Last.fm protocol"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/lastfmlib/"
+license=('GPL')
+depends=('curl')
+options=('!libtool')
+source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('f6f00882c15b8cc703718d22e1b1871f')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+} \ No newline at end of file