summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2019-02-21 10:24:55 -0500
committerEli Schwartz2019-02-21 10:24:55 -0500
commit71e6d1218257f5a67424172d263b02cdd0079339 (patch)
tree3554a3db8cc589d268d0e7b1abd357099aa66fc5 /PKGBUILD
parent43142d5c915e4794b7b940c2b77435aa386add60 (diff)
downloadaur-lastpass-cli-git.tar.gz
upgpkg: lastpass-cli-git 1.3.1.r8.gb2095ad-1
makedepend on bash-completion to guarantee the bash completion can be installed, add completions for fish, zsh
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59da2813b49f..52e7cd51e15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=lastpass-cli-git
-pkgver=1.2.2.r4.g8d086f6
+pkgver=1.3.1.r8.gb2095ad
pkgrel=1
pkgdesc="LastPass command line interface tool (git version)"
arch=('i686' 'x86_64')
url="https://lastpass.com/"
license=('GPL2')
depends=('openssl' 'curl' 'libxml2')
-makedepends=('asciidoc' 'git' 'cmake')
+makedepends=('git' 'asciidoc' 'cmake' 'bash-completion')
optdepends=('xclip: clipboard support'
'pinentry: securely read passwords')
provides=("${pkgname%-git}")
@@ -42,4 +42,7 @@ check() {
package() {
cd "${srcdir}/${pkgname%-git}/build"
make DESTDIR="${pkgdir}/" install install-doc
+
+ install -Dm0644 ../contrib/lpass_zsh_completion "${pkgdir}"/usr/share/zsh/site-functions/_lpass
+ install -Dm0644 ../contrib/completions-lpass.fish "${pkgdir}"/usr/share/fish/completions/lpass.fish
}