summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2022-01-16 14:25:52 +0100
committerhaawda2022-01-16 14:25:52 +0100
commitac52ca59ea2346f66eee8dc189d3957a80eaedbf (patch)
treeee5d7fb66d99867376f8d02bf6aa013f77250471 /PKGBUILD
parent136fbfa5e7ad9ed0e305519887c635995a7825b9 (diff)
downloadaur-ac52ca59ea2346f66eee8dc189d3957a80eaedbf.tar.gz
add patch for table of contents in texinfo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3db1ddce6dbc..f41933781c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=latex-mk
pkgver=2.1
-pkgrel=3
+pkgrel=4
pkgdesc="tool for managing LaTeX projects"
arch=('any')
url="http://latex-mk.sourceforge.net"
@@ -17,19 +17,27 @@ optdepends=('cups: Common UNIX Printing System(tm)'
'tgif: Interactive 2-D drawing facility under X11'
'transfig: Utilities for converting XFig figure files')
source=(http://downloads.sourceforge.net/latex-mk/$pkgname-$pkgver.tar.gz
- ${pkgname}.profile)
-md5sums=('6a9fd9ec2de0169297c1d0228a41fa2b'
- '3fb6cd18ba64619cfb658fc92d85db92')
+ ${pkgname}.profile texinfo.patch)
+sha256sums=('6e9df1c60dafdadccc00c44dc966330fe300256dcb829cd1b04647d7b7956dde'
+ '5b75ef55c25e44ca78e8b85d1b0d116f5d5532a880b1952d9e9921b2ddda5765'
+ '46cc5680538d62e0c5e8162a36ae69ce114139a217430ad382859a42c8b6094b')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 < "$srcdir"/texinfo.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr
make
}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
install -d ${pkgdir}/etc/profile.d
+
install -D -m755 ${srcdir}/${pkgname}.profile \
${pkgdir}/etc/profile.d/${pkgname}.sh
}