summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhotonQuantum2020-10-20 13:43:36 +0800
committerPhotonQuantum2020-10-20 13:43:36 +0800
commit9370baa428e2fea17958002a234a2ed411bfd1b2 (patch)
treeb441d04c789dd08a554b5e3411e36275309a1609 /PKGBUILD
downloadaur-latex-sjtutex.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..696f6e2b7c33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: LightQuantum <self at lightquantum dot me>
+
+pkgname=latex-sjtutex
+pkgver=1.0.0RC7
+pkgrel=1
+pkgdesc="Macro Packages and Scripts for SJTU TeX users"
+arch=(any)
+url="https://github.com/sjtug/SJTUTeX"
+license=('LPPL')
+depends=('texlive-core')
+makedepends=('git' 'unzip' 'zip')
+install="${pkgname}.install"
+source=('https://github.com/sjtug/SJTUTeX/releases/download/1.0.0rc7/sjtuthesis.tds.zip')
+md5sums=('5e4dbcaf104629075a86d6e6023aec19')
+
+package() {
+ mkdir -p $pkgdir/usr/share/texmf-dist/
+ unzip -o -q sjtuthesis.tds.zip -d $pkgdir/usr/share/texmf-dist/
+}