summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorknedl1k2023-07-27 00:06:53 +0200
committerknedl1k2023-07-27 00:06:53 +0200
commitb83973898725d3a30f74f28a84206211382b3803 (patch)
tree215585a1cba9f482463abfb4796a714077acd357 /PKGBUILD
parent671006c529c89e0788f2f8ed3fec0720251a812b (diff)
downloadaur-b83973898725d3a30f74f28a84206211382b3803.tar.gz
fixed build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 995582865d27..4b48c7ce1c73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: knedl1k <knedl1k at duck dot com>
# Contributor: Jan Oliver Oelerich <jan.oliver.oelerich@physik.uni-marburg.de>
pkgname=latex-template-pss
@@ -5,24 +6,29 @@ pkgver=1
pkgrel=1
pkgdesc="LaTeX template for the physica status solidi journal"
arch=('any')
-url="http://www.wiley-vch.de/publish/en/journals/alphabeticIndex/2133/?jURL=http://www.wiley-vch.de:80/vch/journals/2133/2133_authors.html"
-license=('')
+url="https://www.wiley-vch.de/publish/en/journals/alphabeticIndex/2133/?jURL=http://www.wiley-vch.de:80/vch/journals/2133/2133_authors.html"
+license=()
groups=()
-depends=('texlive-core')
+depends=('texlive-basic')
makedepends=('unzip')
optdepends=()
backup=()
install=texlive.install
options=()
-source=(http://www.wiley-vch.de/vch/journals/2133/public/pss_template_latex.zip)
-md5sums=('a1e5820088aa0417f12ce085fd07caa4')
+source=(https://www.wiley-vch.de/vch/journals/2133/public/pss_template_latex.zip)
+md5sums=('570b8eb99f55e4c01aa397dd49745d35')
build() {
- cd ${srcdir}/pss_template_latex
+ cd ${srcdir}/PSS_latex
+}
+
+package(){
install -m 0644 -D readme.txt ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/readme.txt
install -m 0644 -D wiley2sp.cls ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/wiley2sp.cls
install -m 0644 -D w2sp-pss.clo ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/w2sp-pss.clo
- install -m 0644 -D w-greek.sty ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/w-greek.sty
install -m 0644 -D pss.bst ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/pss.bst
+ install -m 0644 -D caption.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/caption.sty
+ install -m 0644 -D caption3.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/caption3.sty
+ install -m 0644 -D subfig.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/subfig.sty
}