summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2016-06-10 13:25:43 -0400
committerChris Severance2016-06-10 13:25:43 -0400
commit7f5a07e7e1b43fd9edc924679145c65665770426 (patch)
tree110b52513ff4a92b61fb60ed1e5f5d90a524fdbd /PKGBUILD
parentd73d46e1942e4f4054e38b515b92f9dd047eaf03 (diff)
downloadaur-7f5a07e7e1b43fd9edc924679145c65665770426.tar.gz
Fix lib-test-common.so
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e70986cf85cb..d4392c9ac560 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,9 @@
# Contributor: philomath <philomath868 AT gmail DOT com>
# Contributor: Sebastien Binet <binet@farnsworth>
+# Build conflicts with docbook-xml-dtd
+# Must reinstall docbook-xml to repair
+
set -u
pkgname='latrace'
pkgver='0.5.11'
@@ -12,7 +15,7 @@ arch=('i686' 'x86_64')
url='http://people.redhat.com/jolsa/latrace/index.shtml'
license=('GPL3')
depends=('glibc')
-makedepends=('asciidoc')
+makedepends=('asciidoc' 'xmlto' 'docbook-xml' 'docbook-xsl')
_verwatch=("http://people.redhat.com/jolsa/${pkgname}/download.shtml" "dl/${pkgname}-\([0-9\.]\+\)\.tar\.bz2" 'l')
source=("http://people.redhat.com/jolsa/latrace/dl/${pkgname}-${pkgver}.tar.bz2")
sha256sums=('3b5afacafa8c1f9f00fb911466f4e2944162aaedfd81805f54e34c22652dbdd5')
@@ -22,6 +25,7 @@ prepare() {
cd "${pkgname}-${pkgver}"
aclocal
autoconf
+ sed -i -e 's/CONFIG_ARCH_HAVE_TEST="y"/CONFIG_ARCH_HAVE_TEST="n"/' 'configure'
./configure --prefix='/usr' --sysconfdir='/etc'
set +u
}