summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Neumann2017-12-21 14:11:59 +0100
committerJan Neumann2017-12-21 14:11:59 +0100
commit72157c7378e3b90c7d35354edcd5f27f7eda4f14 (patch)
tree0c7051cdcbf849b057fcef71b6e75cffaf334e03 /PKGBUILD
parent130bb7e2eaa4ec9472402db266e9f4bc8702c97f (diff)
downloadaur-72157c7378e3b90c7d35354edcd5f27f7eda4f14.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afa72dca99ca..b876da9b9150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=latte-dock-git
gitname=latte-dock
-pkgver=0.7.1.r187.g0077029
+pkgver=0.7.1.r199.gf1e4d45
pkgrel=1
-pkgdesc='Replacement dock for Plasma desktops, providing an elegant and intuitive experience for your tasks and plasmoids- git version'
+pkgdesc='Latte is a dock based on plasma frameworks that provides an elegant and intuitive experience for your tasks and plasmoids'
arch=('i686' 'x86_64')
url='https://cgit.kde.org/latte-dock.git/'
license=('GPL')
@@ -18,25 +18,26 @@ source=("git+git://anongit.kde.org/latte-dock.git")
sha256sums=('SKIP')
pkgver() {
- cd ${gitname}
+ cd ${gitname}
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+
}
build() {
- cd ${gitname}
+ cd ${gitname}
- mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_L10N_BRANCH=trunk \
-DKDE_L10N_AUTO_TRANSLATIONS=OFF \
-DCMAKE_BUILD_TYPE=Release ..
- make fetch-translations
+ make fetch-translations
}
package() {
- cd ${gitname}/build
+
+ make -C ${gitname}/build DESTDIR=${pkgdir} install
- make DESTDIR=${pkgdir} install
}