summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordoragasu2019-06-29 20:47:01 +0200
committerdoragasu2019-06-29 20:47:01 +0200
commit216a72f4c1afdbcb8d1cc752d38608b0e8776ebc (patch)
treea5ec81b838471e26039d756e8c76c2c67370bf3c /PKGBUILD
parent085a6c398687a315c361cbbad3f48f481756252b (diff)
downloadaur-216a72f4c1afdbcb8d1cc752d38608b0e8776ebc.tar.gz
Update to version 3.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 8 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba8c42ca452d..cb1549246742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,26 @@
# http://www.latticesemi.com/latticediamond#linux
# Then put these files in the build directory and retry.
-_version=3.10
-_sp=3
-_build=144.3
-_base=111-2
+_version=3.11
+_base=396-4
pkgname=lattice-diamond
pkgdesc='Lattice Diamond design software'
url=http://www.latticesemi.com/
license=('custom')
-pkgver=${_version}.${_sp}.${_build}
+pkgver=${_version}
pkgrel=1
arch=('x86_64')
install=$pkgname.install
source=("http://files.latticesemi.com/Diamond/${_version}/diamond_${_version/"."/"_"}-base_x64-${_base}-${arch}-linux.rpm"
- "http://files.latticesemi.com/Diamond/${_version}.${_sp}/diamond_${_version/"."/"_"}-sp${_sp}_x64-${_build/"."/"-"}-${arch}-linux.rpm"
- "${pkgname}.png"
- "${pkgname}.desktop"
+ "${pkgname}.png"
+ "${pkgname}.desktop"
"${pkgname}.install")
-sha512sums=('423f4df79c3f07a7cf9cfd17914019f3c06187c4c1a04f13d48e255d3f75dfea2e1e9641506da59c06e276bef46737c14f502df668a3a7ac6ebe63a3cdd4cd1d'
- '316aca87646e0b59ea5b4bd7c982f8dc39540d5d0e25f159e91a9f53c2754dc2d3e5f24a0cc1c3c7a6ae293f8bc6759b08a54260691708ae89b961ac66b04b0d'
+sha512sums=('d4f0e2ca10c8160b16fec3e1cb0d72538d452719fd6b10e3109c63d91a5862ce392479276ab3865c0a1469fe7145cafa9fc9d7c89b3827417447aa21fff7ec36'
'772fa260bb1a4ed7c4e328a99b3cd16b625e8880d7731abbe0cd59dbe4d743265e169a26ceba7b619a87c1cb9638a268a5501d3358863171ee808e59b2d3b0ac'
- 'b5365ac137c6114bdd3e1d6bd1f9e2f8f5306cbf763d457190567c0f8d3086bf3dde11f50a22d35e759b62860f0014c66d631d463fd369d09162905fd5732c07'
+ '77f42fd480370c3a8bfe47083683c6ae22eaa8cf155426ce6983f183379efc8e70a248e8bb56080ff274046251afacbbba9cf3456c0fbcfd899c16053b13707c'
'0f6f4463e1b1266a151afaaf6fefb3d69b712fafd6f2fa20beb211a3f9dd4db216be7255cc8fddaac946534754739c13406476fc6474236e7505bcd033a71d81')
options=('!strip')
-#PKGEXT=".pkg.tar" # The package is over 3 GB, uncomment this line if you prefer not compressing it
+#PKGEXT=".pkg.tar" # The package is about 4 GB, uncomment this line if you prefer not compressing it
prepare() {
# Extract all the packages from base
@@ -42,35 +38,6 @@ prepare() {
echo ' done!'
done
- # Apply service pack
- cd ${srcdir}/usr/local/diamond/${_version}_x64
- for directory in bin cae_library data docs embedded_source examples ispfpga module synpbase tcltk
- do
- echo -en "\tPatching ${directory}..."
- cp -rpf sp/${directory} ./
- echo ' done!'
- done
- rm -rf sp
-
- # Update version information and installation history
- echo -en "\tUpdating version information..."
- sed -i "1iDiamond_x64 Update Build ${pkgver} Update Date: `LANG=C date`" \
- ${srcdir}/usr/local/diamond/${_version}_x64/data/installation_history.txt
-
- for file in data/ispsys.ini ispfpga/data/ispsys.ini
- do
- awk -i inplace 'BEGIN { FS = "="; minor = ARGV[2]; ARGV[2] = ""; bnum = ARGV[3]; ARGV[3] = ""; build_rev = ARGV[4]; ARGV[4] = ""};
- {
- if ($1 == "MinorVersion")
- printf "%s=%s\n", $1, minor
- else if ($1 == "BuildNumber")
- printf "%s=%s\n", $1, bnum
- else if ($1 == "ProductType")
- printf "%s=%s\n", $1, build_rev
- else
- printf "%s\n", $0
- }' ${file} $(echo ${pkgver} | cut -f 2,3 -d'.') ${_build} ${pkgver}
- done
echo ' done!'
}