summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-06-22 13:45:24 +0300
committerCaleb Maclennan2020-06-22 13:45:24 +0300
commit52cf265a81da4e88fe417c8e3262bf12353782d5 (patch)
tree3f9ef53de158a2a722ac35d8b25a5c86ea6b935d /PKGBUILD
downloadaur-lausanne-font.tar.gz
Initial upload: lausanne-font 1.005-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48562630b35d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_font=lausanne
+pkgbase=$_font-font
+pkgname=("otf-$_font" "ttf-$_font")
+pkgver=1.005
+pkgrel=1
+pkgdesc='A luxury serif typeface borrowing from classic Didot with a hint of Copperplate'
+url="https://www.neogrey.com/portfolio/$_font-free-font"
+arch=('any')
+license=('custom:FFPU')
+makedepends=('hq')
+source=("$_font-$pkgver.zip::https://dl.dafont.com/dl/?f=${_font/-/_}"
+ "font-licenses.html::https://www.neogrey.com/font-licenses")
+sha256sums=('47b9da93f9f34b596cbcf832a04bb3a2285075d9588f0133946f6e38ec3a18f5'
+ 'SKIP')
+
+prepare() {
+ hq article text < font-licenses.html > FFPU.txt
+}
+
+package_otf-lausanne() {
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}
+
+package_ttf-lausanne() {
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}