summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeon Plickat2019-12-10 02:00:53 +0100
committerLeon Plickat2019-12-10 02:00:53 +0100
commiteee6b826ecd5b0cdd13e59314f51a2ba77ae2219 (patch)
tree3e5c46d5a89499281772862b0ec105ec05c15d33 /PKGBUILD
downloadaur-eee6b826ecd5b0cdd13e59314f51a2ba77ae2219.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4c55fc090f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=lavalauncher-git
+pkgver=r38.gd95f906
+pkgrel=1
+pkgdesc='A simple launcher panel for Wayland'
+arch=(x86_64)
+url='https://git.sr.ht/~leon_plickat/lavalauncher'
+license=(GPL3)
+depends=(cairo wayland wayland-protocols scdoc)
+makedepends=(git gcc make)
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}::git+${url}" 'Makefile.patch')
+sha256sums=('SKIP' '9015bf10858ff1743ef56d2661b14ddf929e09c3c9677be26477a41c90014655')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare()
+{
+ cd "${pkgname%-*}"
+ patch -Np1 -i ../Makefile.patch
+}
+
+build()
+{
+ make -C "${pkgname%-*}"
+}
+
+package()
+{
+ make -C "${pkgname%-*}" PREFIX=/usr DESTDIR="$pkgdir/" install
+}