summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEdu4rdSHL2022-01-12 03:48:31 -0500
committerEdu4rdSHL2022-01-12 03:48:31 -0500
commitd9fcaacf4465ead81f349b604d1efcb17b95e03f (patch)
treed7143d194d9ab6bb6aa307e3dc334ee98298c91f /PKGBUILD
parent26ea0c3a76897b8d338b93ecd08680afc9116987 (diff)
downloadaur-d9fcaacf4465ead81f349b604d1efcb17b95e03f.tar.gz
Fix package - source was moved to Gitlab.
Signed-off-by: Edu4rdSHL <edu4rdshl@protonmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acdcf34395c7..c1d5c5f91ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgbase=lazarus-svn
pkgname=('lazarus-svn' 'lazarus-svn-gtk2' 'lazarus-svn-qt5')
-pkgver=r64717
+pkgver=r61931.b8f2e92f03
pkgrel=1
+epoch=1
pkgdesc='Delphi-like build environment for FreePascal.'
arch=(x86_64)
url=https://www.lazarus-ide.org/
license=('GPL2' 'MPL' 'custom:modifiedLGPL')
conflicts=('lazarus')
-makedepends=('subversion' 'fpc' 'fpc-src' 'gtk2' 'qt5pas' 'rsync')
+makedepends=('git' 'fpc' 'fpc-src' 'gtk2' 'qt5pas' 'rsync')
optdepends=('perl: to run some scirpts in the tools directory.'
'gtk2: to compile gtk2 apps.'
'qt5pas: to compile qt5 apps and use help viewer')
provides=('lazarus')
-source=("$pkgbase::svn+https://svn.freepascal.org/svn/lazarus/trunk")
+source=("$pkgbase::git+https://gitlab.com/freepascal.org/lazarus/lazarus.git")
sha512sums=('SKIP')
pkgver() {
cd $pkgbase
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {