summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikhail Swift2020-12-18 18:21:07 -0500
committerMikhail Swift2020-12-18 18:21:07 -0500
commita2c22d28bfa16cc79c2fa3e5d0a270bb33edb3db (patch)
tree0261978abf5c33bd6e48a733c97779d82166d957 /PKGBUILD
parent9cddfcbb0e8e12c10e1dbf780aa82c7d05cb7e6c (diff)
downloadaur-a2c22d28bfa16cc79c2fa3e5d0a270bb33edb3db.tar.gz
Un-doing disable of CGO to be inline with lazydocker's build pipeline
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c71b90c4a0e3..3a2a75dd124a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mikhail Swift <mikhail.swift@gmail.com>
pkgname=lazydocker
pkgver=0.10
-pkgrel=2
+pkgrel=3
pkgdesc='A simple terminal UI for docker and docker-compose, written in Go with the gocui library.'
arch=('1686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://github.com/jesseduffield/lazydocker'
@@ -15,7 +15,6 @@ build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_ENABLED=0
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build -o ${pkgname} -ldflags "-extldflags ${LDFLAGS} -s -w -X main.version=${pkgver}" main.go
}