summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikhail Swift2020-05-25 11:26:30 -0400
committerMikhail Swift2020-05-25 11:26:30 -0400
commitc4ae455a5764977bbf2b50c48278c5bbd2cd2ff6 (patch)
treeacf5a39596b1fef0434936c80cd7fbefeb5e48b7 /PKGBUILD
parent93c151fd8b3270c7043c7b00615d6618c5d77188 (diff)
downloadaur-c4ae455a5764977bbf2b50c48278c5bbd2cd2ff6.tar.gz
Update PKGBUILD to follow new go package guidelines
* Use the wiki's new guidelines for go packages to build lazydocker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31589bd1936d..a80bc7583b8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mikhail Swift <mikhail.swift@gmail.com>
pkgname=lazydocker-git
_pkgname=lazydocker
-pkgver=0.5.4.r4.gc04867b
+pkgver=0.8.r6.g10617da
pkgrel=1
pkgdesc='A simple terminal UI for docker and docker-compose, written in Go with the gocui library.'
arch=('1686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
@@ -21,14 +21,11 @@ pkgver() {
build() {
cd "${_pkgname}"
- go build \
- -gcflags=all=-trimpath=${PWD} \
- -asmflags=all=-trimpath=${PWD} \
- -ldflags=-extldflags=-zrelro \
- -ldflags=-extldflags=-znow \
- -ldflags "-s -w -X main.version=${pkgver}" \
- -o ${_pkgname} \
- main.go
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o ${_pkgname} -ldflags "-extldflags ${LDFLAGS} -s -w -X main.version=${pkgver}" main.go
}
package() {