summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfuero2018-08-10 19:26:41 +0200
committerfuero2018-08-10 19:26:41 +0200
commitb029b9d35845ca9f2bdce91008407b61ccc93c85 (patch)
tree881b8c24afe9375270a1302d5932812bf140404d /PKGBUILD
parent9949a1dcc609fadb0cde84e2e0fdd95643aea05a (diff)
downloadaur-b029b9d35845ca9f2bdce91008407b61ccc93c85.tar.gz
Adds conflicts/provides
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75c0d4761669..7bc3d3f06c6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : fuero <fuerob@gmail.com>
pkgname='lazygit-git'
pkgdesc='A simple terminal UI for git commands'
-pkgver=r320.a8c6f31
+pkgver=r333.f20121c
pkgrel=1
_repo_prefix='github.com/jesseduffield'
_repo_name="${pkgname/-git}"
@@ -10,6 +10,8 @@ license=('MIT')
arch=('x86_64')
makedepends=('go-pie' 'git')
depends=('glibc')
+conflicts=('lazygit')
+provides=('lazygit')
_commit='master'
source=("git+https://${_repo_prefix}/${_repo_name}#commit=${_commit}")
sha512sums=('SKIP')
@@ -34,7 +36,7 @@ clean() {
build () {
cd "src/${_repo_prefix}/${_repo_name}"
- go build -i -v -ldflags "-w -s -X main.Rev=${pkgver##*.} -X main.builddate=`date -u +%Y%m%d.%H%M%S`" -o ${_repo_name}.bin
+ go build -x -i -v -ldflags "-X main.Rev=${pkgver##*.} -X main.builddate=`date -u +%Y%m%d.%H%M%S`" -o ${_repo_name}.bin
}
package () {