summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjohnnybash2021-04-12 17:13:22 +0200
committerjohnnybash2021-04-12 17:13:22 +0200
commit8ede1936cb61de857decf3ea8ab3783c0502fdb3 (patch)
treea254cf1a8266417c96c9b072687f8e0fb688a5b1 /PKGBUILD
parent917c99eee927a21a0ae01257c79bc944af119791 (diff)
downloadaur-8ede1936cb61de857decf3ea8ab3783c0502fdb3.tar.gz
upgpkg: ldapadmin 1.8.3-2
add launcher, trim Description
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 834c22966733..d2991f7b0459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: johnnybash <jb at wachenzell dot org> PGP D126E2910543DE2D
+# Contributor: Tom Wizetek <tom@wizetek.com>
pkgname=ldapadmin
pkgver=1.8.3
-pkgrel=1
-pkgdesc="Linux port of free Windows LDAP Admin (http://ldapadmin.org), client and administration tool for LDAP directory management."
+pkgrel=2
+pkgdesc="Client and administration tool for LDAP directory management"
url='https://github.com/ibv/LDAP-Admin'
arch=('any')
license=('GPL')
@@ -11,7 +12,18 @@ depends=('gtk2')
source=("https://github.com/ibv/LDAP-Admin/releases/download/v${pkgver}/LdapAdmin-x86_64.tar.xz")
sha256sums=('b17a1174fc369a6897147ea3f386bc7f9b4c4608d01a3894b3ee946a5de96c1b')
+cat > ${pkgname}.desktop << EOF
+[Desktop Entry]
+Name=LDAP Admin
+Comment=${pkgdesc}
+Version=${pkgver}
+Exec=/usr/bin/LdapAdmin
+Terminal=false
+Type=Application
+Categories=Network;
+EOF
+
package() {
install -Dm 755 "${srcdir}/LdapAdmin" "${pkgdir}/usr/bin/LdapAdmin"
+ install -Dm 644 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
-