summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-09-26 11:41:43 +0200
committerAlexander F. Rødseth2019-09-26 11:41:43 +0200
commit0939ac6a06693550a2b7b8d893570d857e304e97 (patch)
tree58e8ccc7af5722bb0fcef42b84a5811decfae1ff /PKGBUILD
parent62827a6fcd539e9d62982ed3cd6ed47bf709efc3 (diff)
downloadaur-0939ac6a06693550a2b7b8d893570d857e304e97.tar.gz
Update the description
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 418525b49b9f..34505cd30557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,22 @@
pkgname=ldfpcfix
pkgver=1.0
-pkgrel=3
-pkgdesc='Binary patch /usr/bin/ld to quiet the "contains output sections" warning that appears when compiling with fpc'
-arch=('any')
+pkgrel=4
+pkgdesc='Silence the "contains output sections" warning from /usr/bin/ld'
+arch=(any)
url='https://github.com/xyproto/ldfpcfix'
license=('MIT')
-makedepends=('go' 'git')
+makedepends=(go git)
source=("git+https://github.com/xyproto/ldfpcfix#tag=v$pkgver")
-sha256sums=('SKIP')
+sha256sums=(SKIP)
build() {
- cd "$pkgname"
-
+ cd $pkgname
go build
}
package() {
- install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}
# vim: ts=2 sw=2 et: