summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgnacio Losiggio2019-05-31 20:24:02 -0300
committerIgnacio Losiggio2019-05-31 20:24:02 -0300
commit6875aad83f185220f0890cc61c6acc3ade2078ea (patch)
treec9e0ee4408706be439a5a7b2d356db4242326646 /PKGBUILD
downloadaur-6875aad83f185220f0890cc61c6acc3ade2078ea.tar.gz
Initial commit. Imported from normal package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8aaf0acff7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ignacio Losiggio <iglosiggio@dc.uba.ar>
+pkgname=ldpl-git
+pkgver=3.0.5.r21.72d49f8
+pkgrel=1
+pkgdesc="COBOL inspired language, designed to be expressive, fast, readable and easy to learn."
+arch=('x86_64')
+url="https://www.ldpl-lang.org/"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('git' 'awk')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/Lartu/ldpl.git" "dont-do-mandb.patch")
+md5sums=('SKIP' 'dc344057eee2032c7b49562b507db99a')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i "$srcdir/dont-do-mandb.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/src"
+ make LFLAGS="$LDFLAGS"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/src"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}