summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-01-22 12:01:36 +0800
committerzxp198210052024-01-22 12:01:36 +0800
commit57c6c6a033663562a17a1e55fe8e84e2ca5e626a (patch)
tree09b92fa52471ef288efe40154bb19db40c2339a3 /PKGBUILD
parent49d632733dfdf67043da1645c79949652e14a8e8 (diff)
downloadaur-57c6c6a033663562a17a1e55fe8e84e2ca5e626a.tar.gz
update to 2.8.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb01079332c5..26e672d6ba71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=leafview-bin
_pkgname=LeafView
-pkgver=2.8.2
+pkgver=2.8.3
_electronversion=28
pkgrel=1
pkgdesc="A minimalist image viewer based on Leaflet.js and Electron."
@@ -19,7 +19,7 @@ source=(
"LICENSE-${pkgver}.md::https://raw.githubusercontent.com/sprout2000/leafview/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh"
)
-sha256sums=('ecf05b5da64e41cb5786626e36eb69b741dfb08c0ec051051d756cf134fbce12'
+sha256sums=('ee6ec402490cf06073201b8a0e7ba2662f9f57693f2956670e445a235ac757db'
'17db9845cf37bf3bd6b48095f3c87e40d25f3b48d4d0c38c2e740d45f024e56e'
'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
@@ -28,7 +28,7 @@ build() {
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"