summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyechou2020-12-31 02:54:08 -0600
committerkyechou2020-12-31 02:54:08 -0600
commit43608819e8422eb965e40df32bd4e4b3c948196d (patch)
treec30fc2ca795060609fc6ce41227feab6263f36fb /PKGBUILD
parent15cbd9683f3ec453b721063ff46a587f6430dec4 (diff)
downloadaur-43608819e8422eb965e40df32bd4e4b3c948196d.tar.gz
Update, working with patch 10.25
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c91d0c035977..01bed9928cd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
-# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
+# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=leagueoflegends-git
-pkgver=0.10.12.r0.gc44d767
+pkgver=0.10.25.r2.gffb18ff
pkgrel=1
pkgdesc="League of Legends helper script"
arch=('any')
url="https://github.com/kyechou/leagueoflegends"
license=('GPL3')
-depends=('wine-lol' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap'
- 'lib32-openal' 'lib32-libpulse' 'wget')
+depends=('wine-lol' 'winetricks' 'bash' 'curl' 'lib32-gnutls' 'lib32-libldap'
+ 'lib32-openal' 'lib32-libpulse' 'vulkan-icd-loader'
+ 'lib32-vulkan-icd-loader' 'vulkan-driver' 'lib32-vulkan-driver')
+makedepends=()
+optdepends=("lib32-amdvlk: AMD Vulkan driver"
+ "lib32-nvidia-utils: NVIDIA Vulkan driver"
+ "lib32-vulkan-intel: Intel's Vulkan mesa driver"
+ "lib32-vulkan-radeon: Radeon's Vulkan mesa driver")
+provides=('leagueoflegends')
conflicts=('leagueoflegends')
source=("$pkgname"::'git+https://github.com/kyechou/leagueoflegends')
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -25,5 +32,5 @@ pkgver() {
package() {
cd "$srcdir/$pkgname"
- make install PREFIX="$pkgdir"
+ make DESTDIR="$pkgdir" install
}