summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyechou2022-08-05 13:12:58 -0500
committerkyechou2022-08-05 13:12:58 -0500
commitcb298df276b66e143353cdbfb5954353b00bc816 (patch)
treec899955160a734b738c50e088f1210491dccf8de /PKGBUILD
parent7eb4844dcc042e75ae5fe13d5ce712972d5b6991 (diff)
downloadaur-cb298df276b66e143353cdbfb5954353b00bc816.tar.gz
Update to patch 12.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 098faf1f2284..41a7556256f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
-pkgbase=leagueoflegends-git
-pkgname=(leagueoflegends-git leagueoflegends-ge-git)
-_srcname=${pkgbase%-git}
-pkgver=0.12.6.r3.g61b9381
+pkgname=(leagueoflegends-git)
+_srcname=${pkgname%-git}
+pkgver=12.14.r0.g37e8a6e
pkgrel=1
pkgdesc="League of Legends helper script"
arch=('any')
url="https://github.com/kyechou/leagueoflegends"
license=('GPL3')
-depends=('winetricks' 'bash' 'curl' 'openssl' 'samba' 'mesa-utils'
+depends=('wine-lol' 'winetricks' 'bash' 'curl' 'openssl' 'samba' 'mesa-utils'
'lib32-gnutls' 'lib32-libldap' 'lib32-openal' 'lib32-libpulse'
'lib32-alsa-lib' 'lib32-mpg123' 'lib32-unixodbc' 'lib32-vkd3d'
'vulkan-icd-loader' 'lib32-vulkan-icd-loader' 'vulkan-driver'
@@ -35,18 +34,7 @@ pkgver() {
fi
}
-package_leagueoflegends-git() {
- depends+=('wine-lol')
- conflicts+=('leagueoflegends-ge-git')
-
+package() {
cd "$srcdir/$_srcname"
make DESTDIR="$pkgdir" install
}
-
-package_leagueoflegends-ge-git() {
- depends+=('wine-ge-lol')
- conflicts+=('leagueoflegends-git')
-
- cd "$srcdir/$_srcname"
- make DESTDIR="$pkgdir" install-ge
-}