summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Legner2017-01-22 17:15:25 +0100
committerSimon Legner2017-01-22 17:15:25 +0100
commit2297625ff50f92374e5678be51865b9f8387761a (patch)
tree4a92541487935aad579d11ddbba42653867edb7d /PKGBUILD
downloadaur-2297625ff50f92374e5678be51865b9f8387761a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af77fc4b7a9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+_npmname=lebab
+_npmver=2.7.0
+pkgname=lebab # All lowercase
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Turn your JavaScript ES5 code into readable ES6/ES7"
+arch=(any)
+url="https://github.com/mohebifar/lebab"
+license=('MIT')
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(e233a8039a5ea10fc1573f2a309b7e57bcbdab30)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: