summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFanch The System2020-04-20 16:16:04 +0200
committerFanch The System2020-04-20 16:16:04 +0200
commit741b8c01cc123dc9ee46e7eeb3b3c261f49297f4 (patch)
tree71dbbb5dee996fceb3b1e885947260c314e94a83 /PKGBUILD
downloadaur-741b8c01cc123dc9ee46e7eeb3b3c261f49297f4.tar.gz
Update Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43cbb8e41004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+
+pkgname=leed
+pkgver=1.8.4
+pkgrel=1
+pkgdesc="Leed (short for Light Feed) is a minimalist RSS/ATOM aggregator which offers fast RSS consultation and non-intrusive features."
+arch=(any)
+url="https://github.com/LeedRSS/Leed"
+license=("AGPL-3.0")
+optdepends=('php-apache: to use the Apache web server')
+depends=("php" "mariadb")
+makedepends=("unzip")
+backup=("etc/webapps/leed/apache.conf")
+install=leed.install
+options=(emptydirs)
+
+source=("$pkgname-$pkgver.zip::https://github.com/LeedRSS/Leed/archive/v$pkgver.zip"
+ 'apache.conf'
+ 'leed.perm.sh')
+md5sums=('e94088506f8e4fea6d9512e6e2bf718b'
+ '099b05b5761b964e60e8eb209f1fccf5'
+ '24cc8fa2aa47807bccb1c64d2f6b7198')
+
+
+pkgver() {
+ curl -Is https://github.com/LeedRSS/Leed/releases/latest | awk -F'/' '/^location/ {print $NF}' | sed 's/v//' | sed 's/[^[:print:]]//'
+}
+
+
+
+package() {
+ ### install leed
+ mkdir -p "${pkgdir}/usr/share/webapps/leed"
+ cp -a Leed-$pkgver "${pkgdir}/usr/share/webapps/leed/."
+
+ ### default perm
+ find "${pkgdir}/usr/share/webapps/leed/" -type f -print0 | xargs -0 chmod 0640
+ find "${pkgdir}/usr/share/webapps/leed/" -type d -print0 | xargs -0 chmod 0750
+ install -D -m755 "${srcdir}/leed.perm.sh" "${pkgdir}/usr/bin/set-leed-perm"
+
+ ### apache conf (optionnal)
+ mkdir -p "${pkgdir}/etc/webapps/leed"
+ install -m644 "${srcdir}/apache.conf" "${pkgdir}/etc/webapps/leed/apache.conf"
+
+}