summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:31:21 -0300
committerHugo Osvaldo Barrera2015-06-09 02:31:50 -0300
commit1ee1b45e5702669e54239d86db4f9208cc3fc9a1 (patch)
treee9f3e0f41f855a44b1a3eb00a7e9ef3dc4058bd0 /PKGBUILD
downloadaur-1ee1b45e5702669e54239d86db4f9208cc3fc9a1.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f2823721f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+# Since you need to purchase this game, you'll need to place the zip
+# file provided in the same directory as this PKGBUILD in order to build
+# this package.
+
+pkgname=legendofdungeon
+pkgver=Unicorn
+pkgrel=1
+pkgdesc="A 4 Player Co-op Rogue-Like-like Beat'em'up with Dynamic Lighting on AWESOME Pixel Art."
+group=("games")
+arch=("x86_64")
+url="http://www.robotloveskitty.com/LoD/"
+license=('custom')
+depends=(lib32-libxdmcp lib32-libxau lib32-libxrender lib32-libdrm
+ lib32-libxxf86vm lib32-libxshmfence lib32-libxcb lib32-libx11
+ lib32-libxfixes lib32-libxdamage lib32-mesa lib32-expat lib32-glibc
+ lib32-gcc-libs lib32-glibc lib32-libxcursor lib32-libxext lib32-libx11
+ lib32-mesa-libgl lib32-glu lib32-gcc-libs)
+source=(LegendofDungeon-Linux-${pkgver}.zip::https://manual-download-required)
+md5sums=('87c9099e06a446b8159454b9a03a5912')
+PKGEXT=".pkg.tar"
+
+package() {
+ cd "$srcdir/LegendofDungeon-Linux"
+
+ install -Dm 755 LegendofDungeon.x86 "${pkgdir}/opt/LegendofDungeon/LegendofDungeon"
+
+ find LegendofDungeon_Data -type f -exec \
+ install -Dm 644 {} "${pkgdir}/opt/LegendofDungeon/{}" \;
+
+ install -d "${pkgdir}/usr/bin/"
+ ln -s "/opt/LegendofDungeon/LegendofDungeon" "${pkgdir}/usr/bin/legendofdungeon"
+}