summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-04-10 06:32:31 +1200
committerGeorge Rawlinson2022-04-10 06:32:31 +1200
commit31f88ba101955f9a4bc61c44d28ad014dfdc30a0 (patch)
treec2daba4f30bd7140184f8eefa3f26fe91085c92a /PKGBUILD
parentf516ab2b94f632bd348f7ece312e704a1f3a6aa1 (diff)
downloadaur-31f88ba101955f9a4bc61c44d28ad014dfdc30a0.tar.gz
upgpkg: lemmy-ui 0.16.3-1
New upstream release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb93542c97b6..09776251a26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=lemmy-ui
-pkgver=0.15.4
+pkgver=0.16.3
pkgrel=1
pkgdesc="The official web app for lemmy"
arch=('any')
@@ -9,9 +9,12 @@ url="https://github.com/LemmyNet/lemmy-ui"
license=('AGPL3')
depends=('nodejs')
makedepends=('git' 'yarn' 'python')
-_commit='33d048c9c0bb6520223342a98ce96264986a7059'
-source=("$pkgname::git+https://github.com/LemmyNet/lemmy-ui#commit=$_commit")
-b2sums=('SKIP')
+_commit='de5552f87048aee88f9450ff3e840aa778c4b3ca'
+source=(
+ "$pkgname::git+https://github.com/LemmyNet/lemmy-ui#commit=$_commit"
+ 'git+https://github.com/LemmyNet/lemmy-translations.git'
+)
+b2sums=('SKIP' 'SKIP')
pkgver() {
cd "$pkgname"
@@ -21,8 +24,10 @@ pkgver() {
prepare() {
cd "$pkgname"
- # fetch submodules
- git submodule update --init
+ # setup submodules
+ git submodule init
+ git config submodule.lemmy-translations.url ../lemmy-translations
+ git submodule update
# set UI version
sed -i "s/unknown version/$pkgver/" src/shared/version.ts