summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2019-02-10 16:19:08 -0500
committerTony Lambiris2019-02-10 16:19:08 -0500
commit2bee9f8dda43a3b6c81c0990f6328085dc6fb5da (patch)
tree0df16df338ae354e30a496cc40983fa5b50fb8bb /PKGBUILD
parenta443bd752b564b8a9dd816ca6bc993fb0168f12c (diff)
downloadaur-2bee9f8dda43a3b6c81c0990f6328085dc6fb5da.tar.gz
Compile with version info
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d5d90dcb1b6..293cc19e2d6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lemonade-git
pkgver=v1.1.1.r14.gddbd6c1
-pkgrel=2
+pkgrel=3
pkgdesc="Lemonade is a remote utility tool. (copy, paste and open browser) over TCP."
url="https://github.com/pocke/lemonade"
arch=('x86_64' 'i686')
@@ -35,7 +35,8 @@ build() {
mkdir -p build
export GOROOT="/usr/lib/go" GOPATH="${srcdir}/go"
- go build -ldflags "-s -w" \
+ go build \
+ -ldflags "-s -w -X github.com/lemonade-command/lemonade/lemon.Version=${pkgver}" \
-gcflags="all=-trimpath=${GOPATH}/src" \
-asmflags="all=-trimpath=${GOPATH}/src" \
-o build/lemonade
@@ -44,6 +45,6 @@ build() {
package() {
cd "${srcdir}/go/src/github.com/pocke/lemonade"
- install -Dm755 "./build/lemonade" "${pkgdir}/usr/bin/lemonade"
- install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "build/lemonade" "${pkgdir}/usr/bin/lemonade"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}