summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRonuk Raval2019-05-05 18:12:38 -0400
committerRonuk Raval2019-05-05 18:12:38 -0400
commit18a2b784888e08370c0b518be9ed3b73a237563c (patch)
tree6113842e4a4431bd84d8e24fafea8b046dea8a0c /PKGBUILD
parent34eab9d1900cc5340f2e903c3bd73e18091acfc0 (diff)
downloadaur-18a2b784888e08370c0b518be9ed3b73a237563c.tar.gz
v5.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 16 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd8e03bbee04..5e89b2601589 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,64 +3,49 @@
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=5.8
+pkgver=5.9
pkgrel=1
pkgdesc="Literate programmer's editor, outliner, and project manager"
arch=('any')
url="http://leoeditor.com/"
license=('custom')
-# Many of these are actually developer-only dependencies, but the launch
-# scripts will throw `DistributionNotFound` without them.
-#
-# Upstream is working on fixing their dependency specifications:
-# https://github.com/leo-editor/leo-editor/issues/968#issuecomment-435644438
depends=(
+ python
+ python-setuptools
desktop-file-utils
- jupyter-nbformat
+ shared-mime-info
+
+ python-pyqt5
python-docutils
- python-keyring
- python-pyflakes
+ python-flexx
+ jupyter-nbformat
python-pylint
- python-pypandoc
- python-pyqt5
- python-semantic-version
- python-setuptools
+ python-pyflakes
python-sphinx
- python-wheel
- shared-mime-info
- twine
+ python-future
+ python-six
)
optdepends=('python-pyenchant: spellchecking support')
source=(
- ${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/${pkgver}.tar.gz
- leo-dist.patch
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz
leo.desktop
leo.xml
)
sha256sums=(
- ef8413acebb1a032ef8ba6972eb96179a3cd893eb0dd33bf0b84ca78e3c34e31
- 5140c9daf92eb0b3bacea022bb6a7e46911cb727d8372fdb756a31f8bcd6c8f0
+ 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
)
-prepare() {
+build() {
cd "leo-editor-${pkgver}"
-
- # leo's packaging workflow currently requires several workarounds to
- # function:
- #
- # https://github.com/leo-editor/leo-editor/issues/968#issuecomment-451763826
- patch -p1 < ../leo-dist.patch
+ python setup.py build
}
package() {
cd "leo-editor-${pkgver}"
- # leo's setup.py has a hardcoded clean step that always removes the `build`
- # directory. So providing separate `build()` and `package()` steps is futile.
- python setup.py install --root="$pkgdir/" --optimize=1
-
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 "$srcdir/leo.desktop" "$pkgdir/usr/share/applications/leo.desktop"
install -D -m644 "$srcdir/leo.xml" "$pkgdir/usr/share/mime/packages/leo.xml"