summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-11-27 17:59:38 -0600
committerLuis Martinez2021-11-27 17:59:38 -0600
commit4a96fca7375b6a90552304f345addba0c64d0ede (patch)
tree00138be6e26390516929a10765c2ebefb03bae16 /PKGBUILD
parent695d414bb2ced9a08af14beb99761f685d821fa3 (diff)
downloadaur-4a96fca7375b6a90552304f345addba0c64d0ede.tar.gz
update to 6.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4af7789835f0..9aa9ab515477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Ronuk Raval <ronuk.raval at gmail dot com>
# Contributor: Narrat <autumn-wind at web dot de>
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=6.3
-pkgrel=2
-pkgdesc="Outliner, Editor, and Personal Information Manager written in 100% Python"
+pkgver=6.5
+pkgrel=1
+pkgdesc="Outliner, Editor, and Personal Information Manager"
arch=('any')
url="https://leoeditor.com"
license=('MIT' 'BSD')
depends=(
- 'python-pyqt5>=5.12'
+ 'python-pyqt5'
'python-pyqtwebengine'
'python-asttokens'
'python-docutils'
@@ -20,7 +21,7 @@ depends=(
'python-pylint'
'python-pyflakes'
'python-black'
- 'python-pyshortcuts>=1.7'
+ 'python-pyshortcuts'
'python-sphinx'
'jupyter-nbformat'
'shared-mime-info')
@@ -30,7 +31,7 @@ provides=('leo-editor')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz"
'leo.desktop'
'leo.xml')
-sha256sums=('6a39af710fa53caaf0cda947a0dcb37ba0f6aed9ffe2018954b2e81b3d57725f'
+sha256sums=('cbec84798c1167c76802297ef8c1e39783ced0697b0a257b233585cbc6a4ad21'
'4633876eb91eff206660359ee7da459211e8f87fd73ebbc680fd437c70b63467'
'630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb')
@@ -41,7 +42,7 @@ build() {
package() {
cd "${pkgname}-editor-${pkgver}"
- python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ PYTHONHASHSEED=0 python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
install -Dm644 "$srcdir/leo.desktop" -t "${pkgdir}/usr/share/applications/"
install -Dm644 "$srcdir/leo.xml" -t "${pkgdir}/usr/share/mime/packages/"