summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRonuk Raval2019-08-11 17:17:47 -0400
committerRonuk Raval2019-08-20 20:23:45 -0400
commit5da3e84618fd3ccc1a3f3f7d37894496e46a4424 (patch)
treebe26c9db2cb7d070b5ea03a594b4eb49a190f53b /PKGBUILD
parent18a2b784888e08370c0b518be9ed3b73a237563c (diff)
downloadaur-5da3e84618fd3ccc1a3f3f7d37894496e46a4424.tar.gz
v6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e89b2601589..5c95bcacbda1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=5.9
+pkgver=6.0
pkgrel=1
pkgdesc="Literate programmer's editor, outliner, and project manager"
arch=('any')
@@ -18,9 +18,11 @@ depends=(
python-pyqt5
python-docutils
python-flexx
+ python-meta
jupyter-nbformat
python-pylint
python-pyflakes
+ python-shortcutter
python-sphinx
python-future
python-six
@@ -30,15 +32,21 @@ source=(
${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz
leo.desktop
leo.xml
+ setup.py.patch
+ MANIFEST.in
)
sha256sums=(
- 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
+ 37a534cb5b567cf6cf6a816d9eb8f65aac201a166b050bbe04507182851e4a6c
7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
+ 6212a47d5e6b171dc3bcf845bcae007454145958eab6da441c0b2676e573724a
+ 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
)
build() {
cd "leo-editor-${pkgver}"
+ patch -i ../setup.py.patch
+ cp ../MANIFEST.in ./
python setup.py build
}