summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Straube2017-06-28 18:37:13 +0200
committerMichael Straube2017-06-28 18:37:13 +0200
commita83431b0d04bbf1fef3bd6ba6094409877e3e33d (patch)
tree208c2419106ec8878c52d69ead9e59db528d9e5c /PKGBUILD
parentc9fe3817032522206ca136cf363332165eb2707e (diff)
downloadaur-a83431b0d04bbf1fef3bd6ba6094409877e3e33d.tar.gz
Build out-of-tree
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cf14404e432..50e0bcbf1fe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,22 +12,24 @@ license=('GPL')
depends=('qt5-base' 'hicolor-icon-theme')
makedepends=('qt5-tools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/leozide/leocad/archive/v$pkgver.tar.gz"
- "https://github.com/leozide/leocad/releases/download/v$pkgver/Library-Linux-9781.zip")
+ "$pkgname-$pkgver-library.zip::https://github.com/leozide/leocad/releases/download/v$pkgver/Library-Linux-9781.zip")
sha256sums=('5d3d00a559dc74aed4b2605a8e0ab30722b34267102c57d34d9f0c9f5369df25'
'e3af3ca4eb1ba1c4ee820343876a8be5f8c39bf69c51400a1db176a188f780a8')
-build() {
- cd $pkgname-$pkgver
+prepare() {
+ mkdir -p build
+}
- qmake-qt5 \
+build() {
+ cd build
+ qmake-qt5 ../$pkgname-$pkgver \
INSTALL_PREFIX=/usr \
DISABLE_UPDATE_CHECK=1
make
}
package() {
- cd $pkgname-$pkgver
-
+ cd build
make INSTALL_ROOT="$pkgdir" install
install -Dm644 ../library.bin "$pkgdir"/usr/share/leocad/library.bin
}