summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 16:23:29 +0200
committerfabrixxm2024-04-24 16:23:29 +0200
commitb4641470d2678bc2e46df7fca9deebeca6e9e378 (patch)
tree4baf2313ea94a309fe502619768ad0ed73a8409f /PKGBUILD
parent428efaab10bab20f9fe749e9db95fd684bda2597 (diff)
downloadaur-b4641470d2678bc2e46df7fca9deebeca6e9e378.tar.gz
patch pyproject to not require setuptools-scm to get version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70b8d211398e..391a54c782dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
pkgname=lesana
pkgver=0.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Manage collection inventories throught yaml files, develop version"
arch=('any')
url="https://lesana.trueelena.org/"
@@ -14,18 +14,21 @@ optdepends=(
'python-gitpython: git integration'
)
makedepends=(python-build python-installer python-wheel)
-source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25')
+source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz" pyproject.toml.patch)
+sha256sums=('9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25'
+ '0db3be7a5e6d0246fbc90dd0fc61c5d765cea49c03133c2a6ce4224ec1d6d2f5')
prepare() {
cd "${pkgname}-v${pkgver}"
rm -fr dist/*.whl
+ # patch pyproject to not require setuptools-scm to get version
+ patch --forward --strip=1 --input=../pyproject.toml.patch
}
build() {
cd "${pkgname}-v${pkgver}"
- python -m build --wheel --no-isolation --skip-dependency-check
+ python -m build --wheel --no-isolation
}
package() {