summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTjaart van der Walt2015-06-14 16:46:05 -0500
committerTjaart van der Walt2015-06-14 16:46:05 -0500
commit93492ff0b3b802c6918ca74a4357cf79d9c6d323 (patch)
tree9f58d609f14fe575ac34dd29c5482cd0f77a3b88 /PKGBUILD
downloadaur-93492ff0b3b802c6918ca74a4357cf79d9c6d323.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7407f3158d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tjaart van der walt <aur@tjaart.co.za>
+#
+# This is a modified version of the AUR package lfm, downloading the latest
+# sources from the project's official mercurial repository
+#
+# The latest released version of lfm (2.3 at the time of writing) had a blocking
+# bug for me. This bug appears to be fixed in version control, but no release
+# with this fix has been made yet.
+
+pkgname=lfm-hg
+pkgver=20150522
+pkgrel=1
+pkgdesc="A powerful file manager for the UNIX console. This package downloads the latest source from version control."
+arch=('any')
+url="https://bitbucket.org/inigoserna/lfm"
+license=('GPL3')
+conflicts='lfm'
+depends=('ncurses>=5.0' 'python2>=2.6')
+makedepends=('mercurial')
+source=(hg+https://bitbucket.org/inigoserna/lfm)
+
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/lfm"
+ sed -i '1s,env python,&2,' lfm/*
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/lfm"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}