summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoe Davison2016-03-26 17:50:01 +0000
committerJoe Davison2016-03-26 17:50:01 +0000
commit435c3fccec6a9ccca1eafcd060c181f5b3f25810 (patch)
tree45161b7ab532155a7ac908732fa2181d8901be84 /PKGBUILD
parent98c71610a7ba226d3657abcaba643b017a3bb8e0 (diff)
downloadaur-435c3fccec6a9ccca1eafcd060c181f5b3f25810.tar.gz
apply patch to fix build with latest jsoncpp
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a134a76f57f4..69bdd583f03f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=lgogdownloader
pkgver=2.27
-pkgrel=3
+pkgrel=4
pkgdesc="An open source downloader for GOG.com games, uses the GOG.com API"
url="https://sites.google.com/site/gogdownloader/"
arch=(i686 x86_64)
license=(WTFPL)
-depends=('boost' 'jsoncpp<=1.6.5' 'liboauth' 'rhash' 'tinyxml' 'htmlcxx' 'curl')
+depends=('boost' 'jsoncpp' 'liboauth' 'rhash' 'tinyxml' 'htmlcxx' 'curl')
makedepends=('help2man' 'cmake')
-source=(http://sites.google.com/site/gogdownloader/$pkgname-$pkgver.tar.gz)
-sha256sums=('065132d1079322fa60de8d319ef0fc0a15efbd340f4a02b5b2df21be27d3aff1')
+source=("http://sites.google.com/site/gogdownloader/$pkgname-$pkgver.tar.gz" "fix-jsoncpp.patch::https://github.com/Sude-/lgogdownloader/commit/519cb78d38be04a3af79784b5326e21651ced6e1.patch")
+sha256sums=('065132d1079322fa60de8d319ef0fc0a15efbd340f4a02b5b2df21be27d3aff1'
+ 'b16b3f1d3743567e1d7c241d3074d5e36e40e6fb9b47b666b9d47e63a0f1468d')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -21,6 +22,8 @@ prepare() {
rm -rf build/*
fi
+ patch -p1 <../fix-jsoncpp.patch
+
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
}