summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoe Davison2016-01-20 02:08:45 +0000
committerJoe Davison2016-01-20 02:08:45 +0000
commitc52a56b603c46aea73698333984c6dd432199e73 (patch)
treeaeff6037626e5b0abb4c98567e114260131716d1 /PKGBUILD
parent24e3477b1006940aebb4e7ff9e66e7bda3f81f0c (diff)
downloadaur-c52a56b603c46aea73698333984c6dd432199e73.tar.gz
Update to work with new cmake stuff
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd36cab56f65..12d16053f8a5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,11 @@ pkgver() {
prepare() {
cd $srcdir/${_gitname}
+# This is probably redundant since we flush repos before a rebuild,
+# but we'll need it in the non-git version
+# So it's here for self reference, mostly.
+# Please direct complaints to /dev/null
+
if [ ! -d "build" ]; then
mkdir build
else
@@ -30,6 +35,9 @@ prepare() {
cd build
+# Possible options for -DCMAKE_BUILD_TYPE are Release and Debug
+# Debug has console spew
+
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
}